Another Japan in the World

Jun Aruga's blog.

Install Perl 5.28.0 with thread on Mac

I would note how to install perl with thread, as I needed it to use RNA Sequencing tool: Trinity [1]. I needed to upgrade Perlbrew [2] itself, as I got an error to install perl.

Upgrade Perlbrew.

$ \curl -L https://install.perlbrew.pl | bash

Check available perl list.

$ perlbrew available

Select latest stable Perl 5.28.0 seeing [3].

$ perlbrew install perl-5.28.0 --thread
$ perlbrew switch perl-5.28.0

$ perl --version | head -2

This is perl 5, version 28, subversion 0 (v5.28.0) built for darwin-thread-multi-2level